Document Processing Delay

Incident Report for SPS Commerce

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 20:20 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2025 - 18:44 CDT

Update

We are continuing to investigate this issue.
Posted Jun 06, 2025 - 18:08 CDT

Investigating

We are investigating an open incident with our document processing infrastructure which is potentially causing delays or failures for transactions processing through the system. No data has been lost. We will reconcile all data after we have recovered from the incident to ensure all transactions are processed as expected.
Posted Jun 06, 2025 - 18:05 CDT
This incident affected: Document Processing.