Document Duplication

Incident Report for SPS Commerce

Resolved

A subset of documents were incorrectly reprocessed between 9:45am and 12:08pm CT today. All duplicate documents originated on June 17th and were initially processed between 9:00am and 10:00am CT. Impacted customers will be notified.
Posted Jun 20, 2025 - 13:20 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2025 - 12:41 CDT

Investigating

We are investigating an open incident with our document processing which may have resulted in duplication of previously processed documents. Full scope of duplication is being assessed, though we are no longer duplicating at this time.
Posted Jun 20, 2025 - 12:25 CDT
This incident affected: Document Processing.